I maintain a handful of git accounts at GitHub.com and on private git servers, and have repeated committed to a project using the wrong personality.
My early attempts to avoid this mistake involved scripts to set per-project git parameters, but I've found a more streamlined option.
The approach revolves around the file hierarchy in my home directory: Rather than dumping everything in a single ~/projects directory, they're now in ~/projects/personal, ~/projects/work, etc...
Whenever cloning a new project, or starting a new one, as long as I put it in the appropriate directory, git will chose the behaviors and identity appropriate for that project.
Here's how it works, with 'personal' and 'work' accounts at GitHub.com
ssh-keygen -t ed25519 -P '' -f ~/.ssh/work.github.com
ssh-keygen -t ed25519 -P '' -f ~/.ssh/personal.github.com
I picked up a Dell (Avocent) 2161DS-2 (same as 4161DS?) KVM recently, and needed to use the serial port to upgrade the software.
Naturally, the serial port pinout is non-standard and requires a proprietary cable which comes with the KVM. Dell part numbers 80DH7 and 3JY78 might be involved. I don't have, and have never seen these cables.
I was able to to find the RX, TX and Ground pins and interact with the system using 9600, 8, N, 1.
Pinout in red text |
Is the color coding inside these adaptors standardized? If so this may help. |
The system prints some unsolicited messages ("welcome" or somesuch) a little while after power-up.
Notes from upgrading the firmware from MacOS 12:
# Grab the firmware
URL="https://dl.dell.com/RACK SOLUTIONS/DELL_MULTI-DEVICE_A04_R301142.exe"
wget -P /tmp "$URL"
# Start MacOS tftp service
sudo launchctl load -w /System/Library/LaunchDaemons/tftp.plist
# Extract the firmware (it's a self-extracting exe, but we can open it with unzip)
sudo unzip -d /private/tftpboot "/tmp/$(basename "$URL")" Omega_DELL_1.3.51.0.fl
# Now, using the menu on the KVM serial port, point it toward the MacOS TFTP service
# to retrieve the Omega_DELL_1.3.51.0.fl file
I wrote up an example of using terraform modules and provider aliases to turn up interconnected cloud resources (vpcs / vpc peering / peering acceptance / routes) across multiple cloud regions.
$ dd if=/dev/urandom of=data bs=1000000 count=1
1+0 records in
1+0 records out
1000000 bytes transferred in 0.039391 secs (25386637 bytes/sec)
$ ls -l data
-rw-r--r-- 1 chris staff 1000000 Dec 21 14:10 data
$ shasum data
3de9de784b327c5ecec656bfbdcfc726d0f62137 data
$
$ openssl ts -query -cert -no_nonce < data | hexdump -C
Using configuration from /opt/local/etc/openssl/openssl.cnf
00000000 30 29 02 01 01 30 21 30 09 06 05 2b 0e 03 Continue reading
Initial setup |
network:
version: 2
renderer: networkd
ethernets:
eth0:
dhcp4: no
eth1:
dhcp4: no
bridges:
br0:
addresses: [192.168.1.2/24]
gateway4: 192.168.1.1
interfaces:
- eth0
- eth1
#!/usr/bin/env python2.7
from scapy.all import *
def pkt_callback(pkt):
del pkt[Ether].src
del pkt[Ether].dst
del pkt[IP].chksum
del pkt[UDP].chksum
pkt[IP].dst = '192.168.100.100'
sendp(pkt)
sniff(iface='eth0', filter='udp port 514', prn=pkt_callback, store=0)
chris:~$ grep Hash /etc/ssh/ssh_config
HashKnownHosts yes
chris:~$
|1|NWpzcOMkWUFWapbQ2ubC4NTpC9w=|ixkHdS+8OWezxVQvPLOHGi2Oawo= ecdsa-sha2-nistp256 AAAAE2Vj<...>ZHNLpyJsv
interface Tunnel1
ip nhrp nhs dynamic nbma dmvpn-pool.fragmentationneeded.net
ip vrf ISP_A
ip vrf ISP_B
interface GigabitEthernet8
ip vrf forwarding ISP_A
ip dhcp client default-router distance 10
ip address dhcp
interface FastEthernet0
ip vrf forwarding ISP_B
ip dhcp client default-router distance 20
ip address dhcp
"You can't fool me, there ain't no sanity clause!" |
Broken Time? - Roeland van der Hoorn |
$ sudo ls -l /var/run/docker/netns
total 0
-r--r--r--. 1 root root 0 Feb 1 11:16 1-6ledhvw0x2
-r--r--r--. 1 root root 0 Feb 1 11:16 ingress_sbox
$ sudo ip netns list
$ sudo ln -s /var/run/docker/netns /var/run/netns
$ sudo ip netns list
1-6ledhvw0x2 (id: 0)
ingress_sbox (id: 1)
$
$ ls -l /var/run
lrwxrwxrwx. 1 root root 6 Jan 26 20:22 /var/run -> ../run
$ df -k /run
Filesystem 1K-blocks Used Available Use% Mounted on
tmpfs 16381984 16692 16365292 1% /run
$
mirroring-group 1 local
service-loopback group 1 type tunnel
interface <unused-interface>
port service-loopback group 1
quit
interface Tunnel0 mode gre
source <whatever>
destination <machine running wireshark>
mirroring-group 1 monitor-port
quit
interface <interesting-source-interface-1>
mirroring-group 1 mirroring-port inbound
interface <interesting-source-interface-2>
mirroring-group 1 mirroring-port inbound