Archive

Category Archives for "Networking"

ThousandEyes provides data, visualization tools for multi-cloud environments

For most businesses, the decision of “to cloud or not to cloud” has been answered with a resounding yes. The burning question now is which cloud provider to use, and that has no easy answer because every cloud provider has different pricing models and strengths and weaknesses.The reality is that almost every business of any significant size will embrace the concept of multi-cloud where a combination of Microsoft Azure, Amazon Web Services (AWS), Google Cloud Platform (GCP), and others are used.Multi-cloud rapidly becomes the norm Several factors are driving companies to multi-cloud — some business related and others technical that will continue to force this architecture upon companies. Pricing considerations and avoiding being beholden to a single vendor are a couple of issues that business leaders might be concerned with, whereas tools, innovation and functionality are factors that developers and IT individuals would prioritize when making a choice.To read this article in full, please click here

ThousandEyes provides data, visualization tools for multi-cloud environments

For most businesses, the decision of “to cloud or not to cloud” has been answered with a resounding yes. The burning question now is which cloud provider to use, and that has no easy answer because every cloud provider has different pricing models and strengths and weaknesses.The reality is that almost every business of any significant size will embrace the concept of multi-cloud where a combination of Microsoft Azure, Amazon Web Services (AWS), Google Cloud Platform (GCP), and others are used.Multi-cloud rapidly becomes the norm Several factors are driving companies to multi-cloud — some business related and others technical that will continue to force this architecture upon companies. Pricing considerations and avoiding being beholden to a single vendor are a couple of issues that business leaders might be concerned with, whereas tools, innovation and functionality are factors that developers and IT individuals would prioritize when making a choice.To read this article in full, please click here

Using Webpack to bundle your Workers modules

Using Webpack to bundle your Workers modules

A brief introduction to bundling your Service Worker scripts.

Using Webpack to bundle your Workers modules
Photo by Joyce Romero / Unsplash

// The simplest Service Worker: A passthrough script
addEventListener('fetch', event => {
  event.respondWith(fetch(event.request))
})

The code above is simple and sweet: when a request comes into one of Cloudflare’s data centers, passthrough to the origin server. There is absolutely no need for us to introduce any complex tooling or dependencies. Nevertheless, introduce we will! The problem is, once your script grows even just a little bit, you’ll be tempted to use JavaScript’s fancy new module system. However, in doing so, you’ll have a little bit of trouble uploading your script via our API (we only accept a single JS file).

Throughout this post, we’ll use contrived examples, shaky metaphors, and questionably accurate weather predictions to explain how to bundle your Service Worker with Webpack.

Webpack

Let’s just say Webpack is a module bundler. That is, if you have code in multiple files, and you tie them together like this:

app.js

// Import the CoolSocks class from dresser.js
import { CoolSocks } from './dresser'
import { FancyShoes } from './closet'

Then you can tell webpack to follow all of those Continue reading

If We Care About the Internet, We Have to Be Willing to Do Our Part

Whether it’s playing dungeons and dragons over voice chat with my college friends hundreds of miles away, reading the latest movie reviews for summer blockbusters I’ll watch once they come out on video, or simply paying electrical bills, the Internet has become an important part of my life.

Yet, while I have come to rely on the Internet, I don’t always do what is best for it.

I don’t always patch my connected devices or applications, leaving them vulnerable to compromise and use in a botnet. I don’t look for security when buying an app or a device, let alone look at the privacy policies.

While I know I am hurting the overall security of the Internet, I find myself thinking, “I’m just one person, how much damage could I do?”

Unfortunately, according to one recent survey, there are a lot of people who act just like me. 

The results from the 2018 CIGI-Ipsos Global Survey on Internet Security and Trust* suggest that many users fail to make security a priority as they shop for Internet of Things (IoT) devices. (IoT refers to “scenarios where network connectivity and computing capability extends to objects, sensors and everyday items not normally considered computers, allowing these devices to generate, exchange and consume data with minimal human Continue reading

The Week in Internet News: Governments Shut Down Internet for School Testing

Couldn’t you just take their phones away? The government of Algeria told telecom carriers to shut down Internet service for several hours a day during high school testing season, according to several news reports. The government is trying to prevent the repeat of a situation in 2016, when exam questions were leaked online, reports Al Jazeera. The government of Iraq has taken similar action, the news agency says. It’s unclear how a short shutdown each day will prevent leaks.

Why IoT security is terrible: The headline is certainly catchy, but the IEEE Spectrum suggests that the Internet of things has some special security challenges including nation state hackers that are targeting the systems (although that’s true of other IT systems as well). Another of the six reasons: Many IoT systems, like your connected refrigerator, don’t have dedicated IT security workers looking out for them.

Score one for encryption: Using the encrypted WhatsApp, Syrian school girls banned from attending school in Islamic State-controlled territory, are taking pictures of school work and sharing it with each other, notes NakedSecurity, referencing a report on the BBC. “Education is everything, and it’s our weapon,” one of the girls says.

Not so fast, WhatsApp: Continue reading

The silver lining in the Intel CEO drama

I assume that by now you’ve heard the news that Intel CEO Brian Krzanich has stepped down for reportedly violating the company's strict policy against having relationships with employees. As CFO Bob Swan takes the reigns, the question of who will replace Krzanich is front and center.Several analysts I’ve spoken to even before this happened said they think Intel needs to look to the outside for its next CEO. In its 50-year history, the company has had only six CEOs, all of them insiders. Intel has a reputation as a tough place to work; nobody treads water at Intel. In the volatile Silicon Valley, I found Intel was a place where people either came and went fast or hung around forever. If you are cut out for its culture, expect to be promoted up the food chain rather quickly.To read this article in full, please click here

The silver lining in the Intel CEO drama

I assume that by now you’ve heard the news that Intel CEO Brian Krzanich has stepped down for reportedly violating the company's strict policy against having relationships with employees. As CFO Bob Swan takes the reigns, the question of who will replace Krzanich is front and center.Several analysts I’ve spoken to even before this happened said they think Intel needs to look to the outside for its next CEO. In its 50-year history, the company has had only six CEOs, all of them insiders. Intel has a reputation as a tough place to work; nobody treads water at Intel. In the volatile Silicon Valley, I found Intel was a place where people either came and went fast or hung around forever. If you are cut out for its culture, expect to be promoted up the food chain rather quickly.To read this article in full, please click here

IBM ends China’s 5-year reign atop supercomputer rankings

There’s a shake-up – and a scandal – in the Top500 ranking of the world’s most powerful supercomputers.The U.S. has retaken first place in the Top500 list after five years of dominance by China. Computers built by IBM for the U.S. Department of Energy have pushed the previous two record-holders, both Chinese, into second and fourth place.[ Now see who's developing quantum computers.] But the previous fourth placeholder, Japan’s Gyoukou, is nowhere to be found, after one of its creators was arrested on suspicion of fraud.To read this article in full, please click here

IBM ends China’s 5-year reign atop supercomputer rankings

There’s a shake-up – and a scandal – in the Top500 ranking of the world’s most powerful supercomputers.The U.S. has retaken first place in the Top500 list after five years of dominance by China. Computers built by IBM for the U.S. Department of Energy have pushed the previous two record-holders, both Chinese, into second and fourth place.[ Now see who's developing quantum computers.] But the previous fourth placeholder, Japan’s Gyoukou, is nowhere to be found, after one of its creators was arrested on suspicion of fraud.To read this article in full, please click here

Routing Security & IPv6 at NANOG 73 in Denver

We’ll be at NANOG 73 in Denver, CO, USA this week talking about routing security, MANRS, and IPv6.

The North American Network Operators Group (NANOG) is the professional association for Internet engineering, architecture and operations. Its core focus is on continuous improvement of the data transmission technologies, practices, and facilities that make the Internet function. NANOG meetings are among the largest in the region, bringing together top technologists on a wide range of topics.

Routing Security

On Tuesday, 26 June, at 1:30PM, Andrei Robachevsky will give a talk called, “Routing Is At Risk. Let’s Secure It Together.”

From the session abstract:

“Stolen cryptocurrency, hijacked traffic blocking access to whole countries, derailing vital Web resources for thousands of people. Routing used to fly under the radar. As long as incidents weren’t too bad, no one asked too many questions, and routing security never made it to the top of the to-do list. But these days, routing incidents are regularly making the news, executives are getting nervous, and engineers are under pressure to make sure their network isn’t next. The problem is, you cannot secure your own network entirely by yourself. But you can help secure the global routing system Continue reading

Routing Loop, Failure by Design

I have spent some time studying the CCDE materials. One broken design example that has come up involves route reflector clients that don’t align with the physical topology. This article examines that example and some solutions to the problem.

To illustrate this example we have built the topology below. I used loopback addresses 1.1.1.1 through 6.6.6.6 (based on csr1000v-x). The router on the top is a eBGP neighbor with csr1000v-1 and csr1000v-2. The four routers forming a square in the center have an initial configuration of OSFP and BGP (iBGP as shown). Both Route Reflectors are peered with both clients.

Route Reflector Initial Configuration

//csr1000v-2 shown, csr1000v-3 similar

router ospf 1
router-id 2.2.2.2
passive-interface GigabitEthernet2
network 2.2.2.2 0.0.0.0 area 0
network 10.0.0.0 0.255.255.255 area 0

router bgp 64513
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 64513
neighbor 3.3.3.3 update-source Loopback0
neighbor 4.4.4.4 remote-as 64513
neighbor 4.4.4.4 update-source Loopback0
neighbor 4.4.4.4 route-reflector-client
neighbor 5.5.5.5 remote-as 64513
 Continue reading

Routing Loop, Failure by Design

I have spent some time studying the CCDE materials. One broken design example that has come up involves route reflector clients that don’t align with the physical topology. This article examines that example and some solutions to the problem.

To illustrate this example we have built the topology below. I used loopback addresses 1.1.1.1 through 6.6.6.6 (based on csr1000v-x). The router on the top is a eBGP neighbor with csr1000v-1 and csr1000v-2. The four routers forming a square in the center have an initial configuration of OSFP and BGP (iBGP as shown). Both Route Reflectors are peered with both clients.

Route Reflector Initial Configuration

//csr1000v-2 shown, csr1000v-3 similar

router ospf 1
router-id 2.2.2.2
passive-interface GigabitEthernet2
network 2.2.2.2 0.0.0.0 area 0
network 10.0.0.0 0.255.255.255 area 0

router bgp 64513
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 64513
neighbor 3.3.3.3 update-source Loopback0
neighbor 4.4.4.4 remote-as 64513
neighbor 4.4.4.4 update-source Loopback0
neighbor 4.4.4.4 route-reflector-client
neighbor 5.5.5.5 remote-as 64513
 Continue reading

Routing Loop, Failure by Design

I have spent some time studying the CCDE materials. One broken design example that has come up involves route reflector clients that don’t align with the physical topology. This article examines that example and some solutions to the problem.

To illustrate this example we have built the topology below. I used loopback addresses 1.1.1.1 through 6.6.6.6 (based on csr1000v-x). The router on the top is a eBGP neighbor with csr1000v-1 and csr1000v-2. The four routers forming a square in the center have an initial configuration of OSFP and BGP (iBGP as shown). Both Route Reflectors are peered with both clients.

Route Reflector Initial Configuration

//csr1000v-2 shown, csr1000v-3 similar

router ospf 1
router-id 2.2.2.2
passive-interface GigabitEthernet2
network 2.2.2.2 0.0.0.0 area 0
network 10.0.0.0 0.255.255.255 area 0

router bgp 64513
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 64513
neighbor 3.3.3.3 update-source Loopback0
neighbor 4.4.4.4 remote-as 64513
neighbor 4.4.4.4 update-source Loopback0
neighbor 4.4.4.4 route-reflector-client
neighbor 5.5.5.5 remote-as 64513
 Continue reading